[ miso.vucko @ 24.02.2014. 23:12 ] @
Instalirao sam Ubuntu 13.10, 64 bit kako dual boot na desktop kompjuter na kojem je vec bio instaliran Windows 8.1. Ubuntu je instaliran da se pokreće preko Grub-a ne preko wubi-ja.
No međutim svaki puta prilikom pokretanja kompjutera umjesto Grub-a pokrene se odma Windows 8.1.

Več sam tražio po forumima pa sam našao da moram isključiti opciju brzoga pokretanja, tj da isključim ono hibernacijsko pokretanje (Fast startup) win 8.1.
Ali i dalje se događa ista stvar. Bio san nanovo intalirao Ubuntu da vidiim jesam li mozda pogriješio ali događa se opet ista stvar.
Ima li tko možda kakvo riješenje?
Hvala na odgovorima

Moja kofiguracija je ako nekome slučajno treba da detekciju problema:

AMD Phenom II X4 965 processor
AMD Radeon HD 6670 grafic card
Maxtor 6y080M0 ATA hard disc 1
WDC WD5000 AAKX - 083CA0 ATA hard disc 2
ASRock 970 Extreme3 motherboard
RAM: DD3 8 GB
............................................
BIOS: AMI (OEM) P1.60
[ calexx @ 25.02.2014. 00:11 ] @
Najsumnjivija su dva harda, možda je grub otišao na onaj drugi koji nije startan pa i ne može da se pokrene.

Kako je šta instalirano? Na kom hardu je windows, na kome je ubuntu a na koji je otišao grub prilikom instalacije? Sada verovatno možeš da rešiš problem tako što startuješ onaj drugi hard jer je verovatno tamo otišao grub.
[ miso.vucko @ 25.02.2014. 10:11 ] @
Na hard disc-u:

1. Maxtor 6y080M0 ATA - Ubuntu 13.10

2. WDC WD5000 AAKX - 083CA0 ATA - Windows 8.1

Promjenio sam boot opcije (prioretet podizanja sistema) u BIOS-u s hard disc-a 1 na hard disc 2 ali i dalje ista stvar, tj i dalje se pokrece samo Windows 8.1. Čini mi se da je nešto drugo vjerovatno problem.
[ calexx @ 25.02.2014. 10:39 ] @
Gde si instalirao grub prilikom instalacije Ubuntua? Da li si instalirao grub na sda, sda1, sdb, sdb1 ... ili gde? Da li kod izbora particija prijavljuje baš ovaj redosled pa Maxtor bude sda a WD bude sdb? Probaj da otkačiš jedan pa drugi hard da vidiš šta će da se dešava samo sa jednim. Deluje mi da je grub otišao na pogrešno mesto.

Kako god bude, skini i nareži (na rw, USB ... ) supergrub2 disk, startuj ga, idi na izbor postojećih OS i proveri da li se vidi Ubuntu. Ako se vidi, probaj da ga odatle startuješ a posle je rešenje gruba lak posao.
[ miso.vucko @ 25.02.2014. 11:10 ] @
Uf koliko se sjećam WDC je bio sda a Maxtor sdb.
Pretpostavljam da se kratica "sda" odnosi na fizički hard disc a kratica "sda1" na particiju na hard discu?
Ubuntu 13.10 sam bio instalirao preko USB-a ako je mozda i u tome problem.
Sada cu probati s supergrub2 pa ti javim...
[ miso.vucko @ 25.02.2014. 11:32 ] @
Da te pitam još preko kojega programa stavljaš supergrub2 na USB disc? Ja sam probao preko Rufus-a 1.4.3 pa ne mogu. Je li imas koji drugi za preporučiti?
[ calexx @ 25.02.2014. 15:39 ] @
Odavno koristim Yumi za sve, program za pravljenje multiboot fleške i baš sam jutros nabacio nekoliko linuxa, kao i par alatki, upravo sam probao supergrub2 i radi. Pokreneš program (nema instalacije, odmah radi) pa izabereš stavku pred kraj spiska, Unlisted ISO (GRUB), pokažeš na supergrub2 ISO fajl i to će da radi.

Jeste sda fizički hard, prvi na ploči, sda1 je prva particija na njemu i tako dalje. Isto i za sdb. Nema veze što si instalirao sa fleške, ako je sve prošlo, moralo bi da radi ... ako si za grub izabrao fizički hard a ne particiju. Kako god si radio, pokreni supergrub2 i idi na detektovane OS pa ako je tu Ubuntu, startuj ga. Ako radi, onda sledi nastavak. ;)
[ miso.vucko @ 25.02.2014. 16:24 ] @
Yumi je zakon program hvala šta si mo ga otkrio :-)
Instaliro sma preko njega Grub2 disk i kaad sma ga pokrenuo nije na listi bilo uopće ubuntua, samo windows i boot od gruba2
Imaš danje preporuke? Instalirati Ubintu nanovo ili?
[ calexx @ 25.02.2014. 17:56 ] @
Nešto si prevideo kod instalacije. Ajde pokreni neki live linux (može i čist gparted disk) pa da vidimo šta je gde i kako su diskovi podeljeni na particije.
[ waikiki @ 25.02.2014. 20:35 ] @
Probaj boot repair
http://askubuntu.com/questions...ir-tool-in-an-ubuntu-live-disc

meni je pomoglo kod laptopa gde nakon instalicije nije bilo gruba vec je direktno isao na win. Nakon instalacije boot-repair grub se pojavio!
[ miso.vucko @ 26.02.2014. 15:50 ] @
Pozdrav.
Malo sam imao problema s yumijem ipak.
Probao sma preko njega instalirati na USB Ubuntu linux nanovo. No međutim kada sma htio pokrenuti prilikom restartovanja Ubintu s usb-a nije s enista događalo. Probao sam s nekoliko razlicitih USB-ova ali i dalje ista stvar.
Pa sam opet preko Rufus-a morao instalirati Ubuntu. U svakome slučaju hvala vam na odgovorima.

Instalirao sam Linux Ubuntu nanovo i poslje spojio SATA kabel od hard diska na kojem je windows.
Onda sam preko terminala instalirao grub preko nardedbe :

Code:
sudo grub-mkconfig -o /boot/grub/grub.cfg


Sada normalno radi grub, tj bez problema se podiže i LInux i Windowsi.
Ali našao sam na dodatni problem.
Ne mogu preko Linuxa ući na particiju od hard diska na kojem se nalaze Windowsi.
Tj prijavljuje neku grešku i piše da bi trebalo isključiti hibernaciju.
Ja sam to isključio u windowsima ali ona kada uključim Ubuntu opet ne ne mogu ući na particiju na kojoj je Windows instaliran.

Na drugome forumu su mi rekli da bi problem mogao biti u GPT (GUID Partition Table ). Nisam uopće čuo za to da sada, znam da mi je nešto poznato. Kako mogu provjeriti je li to imam?

Evo stavio sam i sliku da vidite kako to izgleda.

[ calexx @ 26.02.2014. 17:16 ] @
Važno da je deo problema rešen. Za ovo ... liči da bi pomoglo da restartuješ windows pa odradiš normalan restart. Meni se to desilo par puta ali se ne sećam da sam imao problema da opravim. Ili samo restart u windows pa opet restart ... moguće je da windows mora da odradi neki check da se oporavi.
Inače sam podesio da se sve ntfs particije automatski montiraju i onda nema problema a i odmah se primeti ako nešto ne ide. Pošto su mi linux particije promenljive, njih ostavim kako su. Particije obično "montiram" iz Krusejdera, nekako mi je najlakše mada mislim da i Delfin to isto odrađuje.
[ plus_minus @ 26.02.2014. 17:19 ] @
@mico.vucko

Način na koji ja montiram ntfs particije radi na svakoj distribuciji.
Evo procedure, pa probaj i ti.


Napravi direktorijum u svom home folderu. Krsti ga .. shitOS .. npr.



mkdir $HOME/shitOS



(u tom direktorijumu će se kasnije pojavljivati montirana ntfs particija)

Ondak, proveri koji je UUID željenog ntfs fajl sistema



sudo blkid



Ova komanda gore će ti prikazati sve uređaje (particije) po redosledu - (prvo), zatim naziv/"label" particije (drugo), zatim UUID particije (treće) i tip fajl sistema/"fs type" (četvrto), izlistano jedno nakon drugog.

Kopiraj UUID info (samo brojke) za ciljanu ntfs particiju i modifikuj liniju ispod tako da se složi sa tvojom situacijom.

Code:


 UUID=<NUMERIKA> /home/username/shitOS ntfs-3g rwx,uid=1000,gid=1000,dmask=0002,fmask=0003 0 0



** Zameni <NUMERIKA> sa odgovarajućom UUID informacijom (samo brojke bez <, > znakova).
** Zameni /home/username/shitOS sa TVOJIM "username" i imenom za novokreirani direktorijum *(shitOS).
** Sve ostalo (ntfs-3g rwx,uid=1000,gid=1000,dmask=0002,fmask=0003 0 0) - treba da ostane isto..

.. jer to je nova linija koja ide u /etc/fstab

Dakle, sledeće je konzola pa komanda ...



sudo nano /etc/fstab



ili ukoliko voliš GUI, a imaš gedit instaliran,
onda opali ALT+F2 i kucaj

Code:

 
 gksudo gedit /etc/fstab



I kada se prikaže sadržina fajla, dodaj malopre napravljenu liniju za montiranje.
Pre nego što snimiš izmodifikovani fstab fajl, uveri se da je makar jedna prazna linija na samom kraju fajla, to je važno onda kada se montiraju fleške i tako tome slično.

Evo kako bi tvoj fstab trebalo da izgleda ...
(obrati pažnju na podebljanu liniju)

Citat:


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdb1 during installation
UUID=ed9de145-8736-4b9c-b533-debf9809e114 / ext4 errors=remount-ro 0 1
# /home was on /dev/sdb2 during installation
UUID=69695820-8e69-4e9f-b1c4-1d0d45a0fecb /home ext4 defaults 0 2
# swap was on /dev/sdb4 during installation
UUID=5e1e280b-04cb-47ab-b27d-3c0c35542730 none swap sw 0 0
# NTFS partition
UUID=5F3FB46C1E839066 /home/username/shitOS ntfs-3g rwx,uid=1000,gid=1000,dmask=0002,fmask=0003 0 0
#/dev/sdc1 /media/usb0 auto rw,user,noauto 0 0




Kada si sve to odradeo, prilagodio novu liniju svom fstab fajlu, na osnovu datog primera iz konzole:



sudo mount -a



.. i ako se bukvalno ništa ne desi nakon toga, već te konzola samo prebaci u novi red, to je to.
Ako si već montirao nešto, mountovao pre ovoga, možda ćeš dobiti i neku poruku ...
Sve u svemu, restartuj kompjuter i nastavi sa svakodnevnim životom.

A ako ovo neće da radi, onda si definitivno - totalno ukenyao hard disk.

[Ovu poruku je menjao plus_minus dana 26.02.2014. u 18:31 GMT+1]
[ miso.vucko @ 26.02.2014. 17:43 ] @
Uf ovo mi se čini dosta složeno, ja sam još uvik laik :-)
Probao sma restartirat nekolio puta ubuntu i windows ali i dalje ista stvar.

plus_minus koliko je ovo sve sigurna metoda? :-) Da opet nešto ne zeznem? Postoji li šta jednostavnije i malo sigurnije? :-)
Šta rade ti programi Delfin i Krusejder? To su windows ili linux programi?
[ calexx @ 26.02.2014. 18:47 ] @
Ovo je uputstvo za automatsko montiranje particija i ne moraš da ga koristiš, možeš uvek po potrebi da ručno montiraš. Kako uopšte hoćeš da pristupiš ntfs particijama? Krusader i Dolphin su fajl menadžeri, ja uglavnom koristim prvi i iz njega po potrebi montiram. Kubuntu tj KDE ima to na sistemskom nivou i ne mora da se radi ručno, nekada sam na gnome linuxima koristio par programa za automatsko montiranje ali nisam siguran da su apsolutno uspešno odrađivali posao dok ovaj iz KDE to radi bez greške.
[ plus_minus @ 26.02.2014. 20:06 ] @
Citat:
miso.vucko
plus_minus koliko je ovo sve sigurna metoda? Da opet nešto ne zeznem? Postoji li šta jednostavnije i malo sigurnije?
Šta rade ti programi Delfin i Krusejder? To su windows ili linux programi?


Tom metodom je montirana, kao što si mogao da primetiš i swap.. i root i home particija.
Dakle, sve linux particije koje se u toku instalacije definišu, montiraju se uz pomoć fstab-a.
Pa, na osnovu toga, zaključi sam koliko je sigurno.

Krusader i Delfin rade isto što i Nautilus, Thunar, PcManFm, SpaceFm .. mogu da montiraju bilo koju particiju na klik.
A ako instaliraš Krusadera i Delfina, dobićeš i komplet KDE. Vezano je jedno sa drugim.

Ako nećeš greške i brljotine po sistemu, pa da ih posle kačiš ovde po forumu, odradi postupak koji sam opisao (a pisao sam tako da i novajlija može da primeni postupak, ako ništa drugo, potrudio sam se) probaj makar.

Ako nećeš ni da probaš, kojeg stojka ja/mi onda gubimo vreme ovde?



@calexx

Ovaj iz KDE, ponekad neće da ostavi zapamćeno za sledeći put, dakle, radi ponekad sa greškom.
[ calexx @ 26.02.2014. 20:55 ] @
Ja sam podesio da dve ntfs (ili još dve ako je i drugi hard uključen) budu automatski montirane i ne sećam se da je nekada neka nestala. Pa i da jeste, ako prijavi da je nema, onda je ručno dodam ali je to toliko retko da nisam siguran ni da se nekad dogodilo. Linux particije nikad ne montiram automatski (odnosi se na ostale linuxe na nardu/hardovima) nego po potrebi otvorim neku u Krusejderu i onda ona (verovatno) trajno ostane montirana. One mi nisu bitne, važne su mi samo one sa zajedničke ntfs particije gde nekoliko foldera postavim u BookMan i onda direkt idem na njih.
[ plus_minus @ 26.02.2014. 21:52 ] @
Citat:
calexx:One mi nisu bitne, važne su mi samo one sa zajedničke ntfs particije gde nekoliko foldera postavim u BookMan i onda direkt idem na njih.


Pa upravo to radim i ja, samo ručno i isključivo za zajedničke (ntfs) particije. A uvek radim ručno zato što tim načinom nije bitno koji DE se koristi. KDE, lxde, xfce, mate, unity..
Kakav crni miš k-palac.. :) Konzola + nano - zakon za te stvari.
Ako imaš više linuxa i više hardova, ni jedan linux neće montirati po default-u ostale stvari, već samo ono što pripada aktuelnom sistemu, to je valjda odvajkada tako, default behaviour.

--------

Konkretno, meni na ntfs-u stoji apache working direktorijum ili www dir i taj www dir koristim i kada preko windoze upalim wamp.
A izmenjam nešto na windozi, eto instant promena i kada upalim apache2 servis na lindži.

Shared ntfs/apache working dir.
I taj celi postupak montiranja i podešavanja apache servera sa ntfs sam već opisao, ali, na drugom forumu.
Pa, koga interesuje (da ne prevodim ponovo samog sebe) evo ga - ovde.
[ calexx @ 26.02.2014. 22:25 ] @
Kada instaliram neki linux, a u poslednje vreme je uglavnom KDE, odmah podesim automontiranje dve ntfs particije i posle restarta, montirane su mi /, naravno /home i ove dve. Ako hoću da odem na neku particiju na kojoj je drugi linux, samo je izaberem u Krusejderu i ona je montirana i tako ostane i posle restarta. Kada jednom otvorim sve particije na kojima su linuxi, one kasnije sve budu automatski montirane.

Ako pokrenem neki linux koji nije KDE, onda obično u nekom fajl menadžeru otvorim ove dve ntfs particije i montirane su mi do restarta. Pošto slabo trošim takve, mrzelo me da opet razmišljam o automontiranju.
[ plus_minus @ 26.02.2014. 23:05 ] @
^^ Pa pazi, ti sa tvojih .. četeres' i pet različitih distroa na mašini .. .. razumljivo.

Ja volim da se zalepim za jednu i nju trošim. Ali, uvek imam instaliran još jedan distro koji je tu, reda radi. I windows, jel' da?

E, sada trenutno, na "reda radi" particiji, pored glavnog crunchbang-a, stoji i zadnji wattOS, ali, ne sviđa mi se ič.

Pošto si ih isprobao, kamaru njih.. daj preporuči nešto zanimljivo, al' da nije bazirano niti vezano za ubuntu.
Bazirano na debianu, uvek može, ali ne i kada je bazirano na derivatu/ubuntu.

Archbang, npr. ... ako znadeš za neku malečku zafrkanciju tog tipa.. bio bih ti zahvalan.
Skinuo sam ga pre neki dan, probao live.. veoma interesantno i moćno..
.. al' neću da ga trošim, jer, takođe se radi o openbox-u .. to već imam sa #!.

Ajd' pomozi..
[ calexx @ 26.02.2014. 23:30 ] @
Pa muči se i ti malo. ;) Pre tri godine sam ih probao sve redom, sada uglavnom Kubuntu i slično. Tu su mi i (uglavnom KDE) Manjaro, Chakra, Open Mandriva, Open Suse, Kanotix, PCLinuxOS ... a sve ostalo je iz d/u varijante. Trošim Kubuntu, ostale pomalo probam, uglavnom me više ne zanimaju. Kada se pojavi nova verzija instaliram, probam pola sata i vratim se na K.

Navikao sam na neke programe, na neke načine instalacija i sve manje nalazim potrebu da probam dalje. Jedino reda radi.
[ plus_minus @ 26.02.2014. 23:37 ] @
E vidiš.. kad si ga već pomenuo .. Kanotix.. :) lxde varijanta .. hmmm.. 700 i kusur megabajta iso..
Žemo.
[ miso.vucko @ 27.02.2014. 10:55 ] @
Napravio sam sve kako si reko @calexx ali i dalje je neka greska, tj isto stanje kao prije. Je li treba mozda na kraju upisivanaj stih naredbi kliknuti na neki "save" ili tako nešto? Jer kada sma htio izaći iz terminala pisalo mi je da ako izađem da ću ubiti proces.
Evo snimio sam da vidite kako izgleda:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda1 during installation
UUID=6bfdab1c-53e9-4201-9c43-eb762ece944b / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=d4d2d39e-e3a7-4034-a61f-35b88f2ba753 none swap sw 0 0
UUID=DA7282B8728298C1 /home/misovucko/MISONJO ntfs-3g rwx,uid=1000,gid=1000,dmask=0002,fmask=0003 0 0
#/dev/sdc1 /media/usb0 auto rw,user,noauto 0 0

sudo mount -a
[ calexx @ 27.02.2014. 10:59 ] @
A ne, nisam ja ništa rekao za terminal način, ne koristim kompikovane nego samo proste. ;) A ako si nešto editovao u terminalu, naravno da moraš da zapamtiš.
[ miso.vucko @ 27.02.2014. 13:49 ] @
Ispričavam se mislio sam na @plus_minus :-) nemoj zamjeriti ;-)

Kako da "zapamtim" ovu kodnu liniju u teminalu?
[ miso.vucko @ 27.02.2014. 16:00 ] @
Skonto sma kako se mamte linije koda Crtl O sve stisne na tipkkovnici.
Uglavnom ništa od mount-anja particije na kojoj su Windowsi. Prilikom restarstanja opet me pitalo da manualno namjestim particiju pa sam u onome nano prohramu izbrisao tu liniju koda da mi ne stvara probleme a preživiti ću i ovako valjda bez te particije :)

Mislim da je problem neštu u Windowsima 8.1 vjerovatno. Iako sam ja isključio hibernaciju u windowsima na sve moguće načine stalno Ubuntu Linux prijavljuje kao da je uključena.

[email protected]:~$ mkdir $HOME/shitOS
[email protected]:~$ sudo blkid
[sudo] password for misovucko:
/dev/sda1: UUID="6bfdab1c-53e9-4201-9c43-eb762ece944b" TYPE="ext4"
/dev/sda5: UUID="d4d2d39e-e3a7-4034-a61f-35b88f2ba753" TYPE="swap"
/dev/sdb1: LABEL="System Reserved" UUID="4A8A6EAF8A6E976B" TYPE="ntfs"
/dev/sdb2: LABEL="Windows 8.1" UUID="DA7282B8728298C1" TYPE="ntfs"
/dev/sdb3: LABEL="Magazin 2" UUID="01CF191FC9FA7A30" TYPE="ntfs"
/dev/sdb5: LABEL="Magazin 1" UUID="860A58790A586867" TYPE="ntfs"
[email protected]:~$ UUID=DA7282B8728298C1 /home/misovucko/shitOS ntfs-3g rwx,uid=1000,gid=1000,dmask=0002,fmask=0003 0 0
bash: /home/misovucko/shitOS: Is a directory
[email protected]:~$ sudo nano /etc/fstab
[email protected]:~$ sudo mount -a
Windows is hibernated, refused to mount.
Failed to mount '/dev/sdb2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.


Tražio sma malo i po googlu čini se da dosta ljudi ima problema s time.

Uglavnom hvala vam @calexx i @plus_minus na trudu ;-)



[ plus_minus @ 27.02.2014. 20:16 ] @
Jesi li ti napravio direktorijum shitOS ili si napravio direktorijum MISONJO ... ?

Ako si napravio direktorijum shitOS a u fstab stavio MISONJO ili obrnuto, nema teorije da proradi..

To mi još uvek nije jasno..

Inače, kada upališ terminal iz grafičkog okruženja, tebi miš radi, takođe i normalno selektovanje teksta.. :) dakle, možeš i desni klik pa copy.
[ miso.vucko @ 27.02.2014. 22:38 ] @
Bio sam napravio i MISONJO i shitOS :-)
Naravno pazio sam da nanovo za svaki file upisujem posebno.
Probo sam na najmanje 5 različitih fajlova i opet sve isto?
Ima li mozda koji jos drugi način za npr. osposobiti tu windows particiju samo mogućnost čitanja?

Ja sam porobao i preko nekih naredbi šta sam našao na:

http://askubuntu.com/questions/145902/unable-to-mount-windows-ntfs-filesystem-due-to-hibernation

Code:

ls /media
sudo mkdir /media/windows
mount -t ntfs-3g -o ro /dev/sda3 /media/windows


ali sve bez uspjeha :-(
[ calexx @ 27.02.2014. 23:47 ] @
Da li ti je važno automontiranje ili možeš svaki put kod startovanja da pristupiš particijama i montiraš ih?
[ miso.vucko @ 28.02.2014. 08:39 ] @
Važno mi je ipak automontiranje jer ne koristim samo ja kompjuter, pa braća neće znati ili će mu to biti zamorno raditi svaki puta...
[ calexx @ 28.02.2014. 10:26 ] @
Ok. Ja sam na Ubuntu koristio par programa koji to rade, sad se ne sećam imena ali nije teško da se nađu. Mogu kasnije da proverim. Kod KDE nemam tih problema, sve se lako automontira.
[ miso.vucko @ 28.02.2014. 13:46 ] @
Ako stigneš bio bit ti zahvalan ;-)
Probati ću i ja naći još pa ako budem imao uspjeha...
[ vidonk @ 20.04.2014. 23:48 ] @
@Mišo Ne znam kako izgleda taj win8 i da li je do njega (vjerovatno jeste) al pade mi na pamet da probaš u winu desni klik na particiju->propertis->Check disk for errors tako nešto u tom smislu je izgledalo čini mi se pa onda sve štrikiraš pa restart

A ne bi bilo loše da postaviš sliku od Disk Utility-a čisto da vidimo kako to izgleda
[ miso.vucko @ 07.05.2014. 13:04 ] @
Nije bilo rješenja pa sam moro maknuti Ubuntu :-( Već sam probo: u winu desni klik na particiju->propertis->Check disk for errors ali i dalje s eništa nije mjenjalo.
U svakome slučaju hvala na pomoći...