[ Zalutali @ 18.03.2011. 10:47 ] @
Pozdrav,
instalirao sam Vector Linux 5.8, ali imam problem sa refresh rate-om.
Radi na [email protected] a treba na [email protected]
Nema xorg.conf fajla, probao sam da iskonfigurisem(mada nisam siguran koliko sam dobro to uradio) ali onda nece da se startuje x, pa sam morao da ga izbrisem.

Na ovom sajtu http://www.firingsquad.com/hw/2067/LG_L1715S/?viewdesc=1 sam nasao kako treba podesiti horizontalnu i vertikalnu frekvenciju za moj monitor.
Horizontal Frequency : 30 ~ 83 kHz
Vertical Frequency : 56 ~ 75 Hz

Graficka: ATI Rage IIC AGP
Monitor: LG L1715S

Zadnji put sam koristio linux pre nekih par godina na 10-ak dana, tako da nisam bas neki dobar poznavalac linuxa.
Ako bi neko mogao da okaci ceo primer xorg.conf fajla, pa ja samo to da kopiram ako je izvodljivo...bilo bi super...

Hvala :)
[ combuster @ 18.03.2011. 12:09 ] @
Okaci nam /var/log/Xorg.0.log kada pokrenes graficko okruzenje pa da vidimo sta xserver nalazi automatski...
[ Zalutali @ 18.03.2011. 12:30 ] @
Ja sam u medjuvremenu instalirao Vector Linux 6.0-Light-Final
Sada me je prilikom instalacije pitao koju rezoluciju da podesim i ali ne i refresh rate. Primetio sam da je napravio xorg.conf fajl i sad se startuje x, medjutim opet ne mogu/ne znam da podesim zeljeni refresh rate.

xorg.conf
Code:

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/share/X11/rgb"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/TTF"
FontPath     "/usr/share/fonts/OTF"
FontPath     "/usr/share/fonts/Type1"
FontPath     "/usr/share/fonts/misc"
FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load  "glx"
Load  "extmod"
Load  "xtrap"
Load  "record"
Load  "GLcore"
Load  "dbe"
Load  "dri"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "us"    ## KEYBOARD_MAP!
Option  "XkbModel"  ""    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  ""    ## KEYBOARD_VARIANT!
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option        "Protocol" "auto"
Option        "Device" "/dev/input/mice"
Option        "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
 DisplaySize 269 201 # 96 DPI @ 1024x768
  Option "UseEdidFreqs" "1" 
#DisplaySize      340   270    # mm
Identifier   "Monitor0"
VendorName   "GSM"
ModelName    ""
### Comment all HorizSync and VertRefresh values to use DDC:
HorizSync    30.0 - 83.0
VertRefresh  56.0 - 75.0
Option        "DPMS"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option     "probe_sparse"           # [<bool>]
#Option     "accel"                  # [<bool>]
#Option     "crt_display"            # [<bool>]
#Option     "composite_sync"         # [<bool>]
#Option     "hw_cursor"              # [<bool>]
#Option     "force_pci_mode"         # [<bool>]
#Option     "dma_mode"               # <str>
#Option     "agp_mode"               # <i>
#Option     "agp_size"               # <i>
#Option     "local_textures"         # [<bool>]
#Option     "buffer_size"            # <i>
#Option     "tv_out"                 # [<bool>]
#Option     "tv_standard"            # <str>
#Option     "mmio_cache"             # [<bool>]
#Option     "test_mmio_cache"        # [<bool>]
#Option     "panel_display"          # [<bool>]
#Option     "reference_clock"        # <freq>
#Option     "shadow_fb"              # [<bool>]
#Option     "sw_cursor"              # [<bool>]
#Option     "AccelMethod"            # <str>
#Option     "RenderAccel"            # [<bool>]
Identifier  "Card0"
Driver      "mach64"
VendorName  "ATI Technologies Inc"
BoardName   "3D Rage IIC AGP"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport   0 0
Depth     1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
              
Section "Extensions"
Option "Composite" "on"
EndSection


[ combuster @ 18.03.2011. 12:56 ] @
Modeline "[email protected]" 65.00 1024 1048 1184 1344 768 771 777 806 -hsync -vsync

Ovu liniju dodaj u Monitor sekciju:

Code:

Section "Monitor"
 DisplaySize 269 201 # 96 DPI @ 1024x768
  Option "UseEdidFreqs" "1" 
#DisplaySize      340   270    # mm
Identifier   "Monitor0"
VendorName   "GSM"
ModelName    ""
### Comment all HorizSync and VertRefresh values to use DDC:
HorizSync    30.0 - 83.0
VertRefresh  56.0 - 75.0
Option        "DPMS"
Modeline "[email protected]"   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync
EndSection


Tako to treba da izgleda. E sad, jedino nisam siguran vezano za refresh. Backup-uj prvo tvoj aktuelni xorg.conf pa onda experimentisi. Ako nece ovako probaj Modeline "1024x768_60" sve ostalo ostaje isto ili Modeline "1024x768"x60.0

Menjalo se to tokom vremena, odavno nisam imao potrebe da force-ujem rezoluciju i osvezavanje. A sto te maltretira 75Hz na 1024x768, trebalo bi da ti je prikaz dosta jasniji. Meni je 60Hz na CRT-ovima flickerovalo do bola.

Mozda bi cak trebalo prvo da probas sa "1024x768"x60.0 zato sto je to tako navedeno i u Xorg.0.log - pa tek posle probaj sa @ ili _
[ Zalutali @ 18.03.2011. 14:31 ] @
Hvala na odgovoru, combuster.
Probao i nije bilo neke promene.
Od jutros pokusavam ovo da resim, pa sam se vec malo i smorio. Mozda instaliram neki drugi distro, mada mi je VL 5.8 ekstra brz(mnogo laksi od x_ubuntu-a) a nije nesto osiromasen.

Na Linuxu 75Hz meni flickeruje dosta, dok na Windowsu ne primecujem.
Pre par dana sam instalirao Xubuntu na [email protected], ali tamo nema xorg.conf fajla.
Jel moguce nekako da vidim ta podesavanja iz Xubuntu-a, pa da unesem za Vector?
[ combuster @ 18.03.2011. 15:08 ] @
Ma oni nisu ni blizu slicni, vidis koju ti verziju xservera koristi vector, 1.4. Noviji xubuntu tera sigurno preko 1.8 (ja sam trenutno na 1.10) i tu je doslo do mnogo promena, izbacivanje hal-a iz jednacine, xorg.conf vise nije potreban vec se moze koristiti samo za "tuniranje" opcija koje nisu default-ne, tu je i xorg.conf.d direktorijum - mislim razlike su ogromne.

Citat:

Probao i nije bilo neke promene.


Jesi proverio koje je osvezavanje, pise ti u Xorg.0.log a ne znam kako mozes preko GUI-ja to da proveris u Vectoru. Modeline setovanje bi trebalo da ti forsira zeljeno osvezavanje - mozda flickeruje i na 60 ? U stvari ja ne vidim zasto bi ti monitor flickerovao na 75Hz a ne na 60Hz. Ako ti je 1280x1024 na 60Hz - onda je normalno da treperi ali razlika u kvalitetu izmedju 1024x768 na 60 i 75Hz bi svakako tebalo da je na strani 75Hz.

Citat:

Na Linuxu 75Hz meni flickeruje dosta


Da nije do neceg drugog, ne bih rekao da je osvezavanje u pitanju, da drajver nesto ne zeza ? Jel ti se dogadja na svim linux distribucijama koje si probao ?
[ Srđan Pavlović @ 06.04.2011. 19:52 ] @
Ako je u pitanju neki stariji CRT monitor, kojem
das maksimalnu podrzanu rezoluciju + maksimalno
podrzano osvezavanje, znaci dosta star monitor,
oce i onda slika da ima malih "problema".. (distorzije,
treperenja...)

Znam, ja recimo imam jedan stariji CRT 15" monitor (DTK), koji
podrzava i 1024x768 (preporucena mu je 800x600), ali moze da se
stavi i na 1024x768 na 75Hz (to je max rez+freq), i onda se vide
blaga izoblicenja slike i poigravanja... jbg, maksimalno nategnuto sve a star monitor.